Download


The Apache IvyDE distribution is available as an Eclipse™ update site, but you can also download and install it manually from one of our mirrors. We encourage you to verify the integrity of the downloaded files using signatures downloaded from our main distribution directory. You are also invited to look to the ASF subversion if you are interested into contributing to IvyDE.

Update site

You can install Apache IvyDE plugins from the IvyDE update site: http://www.apache.org/dist/ant/ivyde/updatesite.

First you have to configure Eclipse: add the IvyDE update site. In order to do it, follow these steps (Note that for Eclipse 3.4 it may differ):
  • Open the update manager in Eclipse: Help > Software Updates > Find and Install...
  • In the popup window, select Search for features to install, and click Next
  • Then click on New Remote Site...
  • Name: Apache Ivy update site
  • URL: http://www.apache.org/dist/ant/ivyde/updatesite
  • Click OK
  • A new entry "Apache Ivy update site" will appear in the list of update sites
And to proceed to the installation of the plugins from the configured IvyDE update site:
  • Make sure you selected the "Apache Ivy update site" and click Finish to trigger the search for features
  • After some amount of time, you will see the list of available features to install. Select the ones in which you are interested in
  • If Eclipse warns you about non resolved dependencies, click on Select Required
  • To continue click Next
  • Then you have to accept the Apache Software License agreement
  • Eclipse will present you the summary of the plugins to download: click Finish to start downloading
  • After the download, Eclipse will ask you if you really want to install the plugins. Click Install or Install All.
  • It is then recommended to restart Eclipse: click Yes
  • After restarting, the IvyDE plugins should have started. You can check the version of Ivy you are using on the top of the configuration panel of Ivy (Window > Preferences, and select Ivy); or in Eclipse's list of plugins (Help > About Eclipse, click Plug-in Details)

Manual install

Select mirror

You are currently using http://mirror.tcpdiag.net/apache/. If you encounter a problem with this mirror, please select another mirror. If all mirrors are failing, there are backup mirrors (at the end of the mirrors list) that should be available.

Other mirrors:

IvyDE binaries

This distribution contains every binaries ready to be installed in your Eclipse installation.

Download the IvyDE plugins: Uncompress the archive. In there you will find two folders containing the artifacts to deploy in your Eclipse:
  • the IvyDE features features/org.apache.ivyde.*.jar to put in your $ECLIPSE_HOME/features
  • the IvyDE plugins plugins/org.apache.ivyde.*.jar to put in your $ECLIPSE_HOME/plugins

Install the latest Ivy bundle

Get the latest Ivy feature and bundle for the updatesite: And then just copy them respectively in the $ECLIPSE_HOME/features and the $ECLIPSE_HOME/plugins folders.
Then it is recommended to (re)start your Eclipse with the -clean option.

Full sources

The source distribution contains the source files of the plugins, the features and the build system, so you will be able to reproduce the build that create the 2.0.0.final release.

Download: Then look into the distribution for the documentation about how to build it.

Sources from the version control system

The IvyDE sources can be also found on the ASF Subversion repository. You can checkout the trunk by running the command
svn co https://svn.apache.org/repos/asf/ant/ivy/ivyde/trunk ivyde-trunk

Trunk builds

The trunk version of IvyDE is build by a continuous integration server (a Jenkins instance hosted by the ASF).

It is automatically publishing the last build into an updatesite. So you can configure your Eclipse to use it:
https://builds.apache.org/job/IvyDE-updatesite/lastSuccessfulBuild/artifact/trunk/build/

Important note: these are only test snapshots that is not be considered ready for users or even something like an official release. They are dedicated to people willing to understand and contribute to Ivy and IvyDE code. And then any issue you can have with that kind of snaphot should be reported to the ant-dev@ mailing-list and not the ivy-user@ one.

Verify Releases

It is essential that you verify the integrity of the downloaded files using the PGP signature or the SHA1 or MD5 checksums. The checksums are not as strong indicators as the PGP signature.

The PGP signatures can be verified using PGP or GPG. First download the KEYS as well as the asc signature file for the particular distribution. Make sure you get these files from the main distribution directory, rather than from a mirror. Then verify the signatures using
% pgpk -a KEYS
% pgpv apache-ivyde-2.2.0.final-201311091524-RELEASE.zip.asc
or
% pgp -ka KEYS
% pgp apache-ivyde-2.2.0.final-201311091524-RELEASE.zip.asc
or
% gpg --import KEYS
% gpg --verify apache-ivyde-2.2.0.final-201311091524-RELEASE.zip.asc
Alternatively, you can verify the checksums on the files. Unix programs called md5/sha1 or md5sum/sha1sum are included in many unix distributions. *sum is also available as part of GNU Textutils. Windows users can get binary md5 programs from here, here. fsum supports MD5 and SHA1.

We highly recommend to verify the PGP signature, though.

Old releases

Releases described below were made by Jayasoft, and are listed here for historical reason, and should not be considered as Apache software.

IvyDE 1.2.0 - 2006-11-17

- upgrade to Ivy 1.4.1
- NEW: Link Sources to Classes by Artifact Type in Classpath Container (IVYDE-12) (thanks to Peter Blstak)
- FIX: No resolve messages in console (IVYDE-39)

Download on Jayasoft: IvyDE 1.2.0

IvyDE 1.1.0 - 2006-10-09

- upgrade to Ivy 1.4
- several stability improvements
- NEW: enabling user to choose what types get added to the classpath (IVYDE-24)
- NEW: Provide "create ivy aware library" when opening the context menu of an ivy.xml file (IVYDE-21)
- NEW: report view (Windows -> Show View -> IvyDE > Report) (IVYDE-20)
- IMPROVE: Deal with cancel resolve job (IVYDE-30)
- IMPROVE: Support for relative path in the prefence fields when declaring location of ivyconf.xml file. (IVYDE-25) (thanks to Peter Chanthamynavong)
- IMPROVE: store per project settings in a shareable file (namely .settings/org.jayasoft.ivyde.eclipse.prefs) (IVYDE-15)
- FIX: junit classpath not resolved correctly with several IvyDE classpath containers (IVYDE-31)

Download on Jayasoft: IvyDE 1.1.0

IvyDE 1.0.3 - 2006-05-23

- include source in distribution

Download on Jayasoft: IvyDE 1.0.3

IvyDE 1.0.2 - 2006-04-11

- Include IVY 1.3.1 release
- Fix common-logging classloader issue

Download on Jayasoft: IvyDE 1.0.2

IvyDE 1.0.1 (a.k.a. 1.0) - 2006-03-17

- Include IVY 1.3 release

Download on Jayasoft: IvyDE 1.0.1

IvyDE 1.0.0 (a.k.a. 1.0 RC1) - 2006-03-07

- Fix source attachment from class editor

Download on Jayasoft: IvyDE 1.0.0

IvyDE 0.9.7 (a.k.a. 1.0 beta 2) - 2006-02-14

- Fix source attachment for contained in ivycontainer
- Fix startup refresh problem

Download on Jayasoft: IvyDE 0.9.7 beta

IvyDE 0.9.3 (a.k.a. 1.0 beta 1) - 2006-01-25

initial public version
- integration of plugin formerly known as ivyeclipseui
- added IvyClasspathContainer and configuration stuff

Download on Jayasoft: IvyDE 0.9.3 beta


Printer Friendly