JVM compability

Up to Ivy 2.3.x, a minimum of Java 1.4 is required.

Since Ivy 2.4.0, a minimum of Java 5 is required.

Apache Ant

Ivy doesn't require much of Ant and should run correctly on pretty old versions. But it is recommended to use at least Ant 1.6.

Other optional dependencies

The required versions of the Apache HttpClient, Jsch or any optional dependency are to be checked against Ivy's dependency descriptor. In Ivy's source, check for the ivy.xml file at the root. Or the pom.xml of org.apache.ivy#ivy in the Maven Central repository.

Environment / Configuration Requirements

Ivy does not at this time support multithreaded use. It thus should not be used with the ant <parallel> task.